Gentoo kde updating system

* Error: The above package list contains packages which cannot be * installed at the same time on the same system. In my experience, a fresh install is usually far less work than an update after an extended period of time.

(dev-qt/qtwebkit-4.8.7:4/4::gentoo, installed) pulled in by =dev-qt/qtwebkit-4.8.5:4 required by (app-cdr/k3b-2.0.3-r3:4/4::gentoo, installed) ~dev-qt/qtwebkit-4.8.7[aqua=,debug=,abi_x86_32(-)? But, doing a "fresh install" as an upgrade takes a bit of planning and orginization.

systems have been mostly trouble free for many, many years.

Over the last couple of years I only update once a week and a couple of older systems I only update every fortnight.

I have a user consuming most of my CPU time so that's part of the reason why it's slow... I'm trying my jackhammer script yet again, this time duplicating the lines for system and world but without --deep on the first round... As far as I can determine you update your system both very rarely, and using a method, if it deserves the name, that defies description and consistently runs into issues.

The thing seems to have a problem with the --deep flag these days, omitting deep seems to evade a number of the conflicts but that seems to be the ostrich approach... As far as I can determine every now and then someone other than you has a merge issue, posts to the list and either gets their issue resolved or, rarely, has run into a legitimate issue and needs to patch, or wait for a bug to get fixed.

It may be that your proposed change is broken in a way you had not anticipated, or that there is an existing function which performs the same purpose, or that your function may be better off in its own eclass.

If you don't email gentoo-dev first, and end up breaking something, expect to be in a lot of trouble.

gentoo kde updating system-34gentoo kde updating system-64gentoo kde updating system-38gentoo kde updating system-18

However, it is also possible that conflicting dependencies exist such that they are impossible to satisfy simultaneously. Your problem is that the box seems to have not been updated in a long while. The solution is always the copious use of patience and understanding. OTOH, there have been a couple systems where I didn't update for 6 months.This puts me in the position to upgrade only once in a while. Before committing a new eclass to the tree, it should be emailed to the gentoo-dev mailing list with a justification and a proposed implementation.Multiple package instances within a single package slot have been pulled !!! Best regards and good luck with your update, Paul P. I sync almost daily and update if there are no big packages that would interfere with whatever I'm doing. And I didn't even need to figure that out myself, as portage is telling me.into the dependency graph, resulting in a slot conflict: dev-libs/boost:0 (dev-libs/boost-1.62.0-r1:0/1.62.0::gentoo, ebuild scheduled for merge) pulled in by (no parents that aren't satisfied by other packages in this slot) (dev-libs/boost-1.61.0-r1:0/1.61.0::gentoo, installed) pulled in by =dev-libs/boost-1.51.0:0/1.61.0= required by (dev-libs/liborcus-0.11.2:0/0.11::gentoo, installed) ^^^^^^^^^^ dev-libs/boost:0/1.61.0= required by (dev-libs/librevenge-0.0.4:0/0::gentoo, installed) ^^^^^^^^^^ dev-libs/boost:0/1.61.0=[python,python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_5(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/pycuda-2016.1.2:0/0::gentoo, installed) ^^^^^^^^^^ dev-libs/boost:0/1.61.0= required by (app-text/libebook-0.1.2-r1:0/0::gentoo, installed) ^^^^^^^^^^ dev-libs/boost:0/1.61.0= required by (kde-apps/akonadi-1.13.1_pre20160203-r1:4/4::gentoo, installed) ^^^^^^^^^^ =dev-libs/boost-1.55:0/1.61.0= required by (app-office/libreoffice-5.2.3.3-r1:0/0::gentoo, installed) ^^^^^^^^^^ dev-libs/boost:0/1.61.0= required by (dev-db/mysql-connector-c -1.1.6:0/0::gentoo, installed) ^^^^^^^^^^ dev-libs/boost:0/1.61.0= required by (dev-cpp/libcmis-0.5.2_pre20160820:0.5/0.5::gentoo, installed) ^^^^^^^^^^ =dev-libs/boost-1.35.0-r5:0/1.61.0= required by (kde-apps/kdepimlibs-4.14.11_pre20160211-r2:4/4.14::gentoo, installed) ^^^^^^^^^^ dev-libs/boost:0/1.61.0= required by (dev-util/mdds-1.2.2:1/1.2::gentoo, installed) ^^^^^^^^^^ dev-libs/xapian:0 (dev-libs/xapian-1.4.1:0/30::gentoo, ebuild scheduled for merge) pulled in by (no parents that aren't satisfied by other packages in this slot) (dev-libs/xapian-1.2.24:0/1.2.22::gentoo, installed) pulled in by =dev-libs/xapian-1.2*[chert] required by (kde-frameworks/baloo-4.14.3:4/4.14::gentoo, installed) ^ ^^^^ media-video/ffmpeg:0 (media-video/ffmpeg-2.8.9:0/::gentoo, ebuild scheduled for merge) pulled in by =media-video/ffmpeg-2.8.5:0/=[abi_x86_32(-),abi_x86_64(-)] required by (media-plugins/gst-plugins-libav-1.8.3:1.0/1.0::gentoo, installed) ^^^^^^^^^^^^ media-video/ffmpeg:0/= required by (media-plugins/alsa-plugins-1.1.1:0/0::gentoo, installed) ^^^^^^^^^^^^ media-video/ffmpeg:0/= required by (app-cdr/k3b-2.0.3-r3:4/4::gentoo, installed) ^^^^^^^^^^^^ media-video/ffmpeg:0/= required by (kde-frameworks/kfilemetadata-5.28.0:5/5.28::gentoo, installed) ^^^^^^^^^^^^ =media-video/ffmpeg-3.0:0=[vdpau? So I can focus on other things, although in this case, only time will tell how useful I spent my time. You have kde-16.08.1 components installed and those are long gone from the tree.

Leave a Reply